Incident

Outbound emails not working

Resolved | Apr 04, 2024 | 04:54 GMT-07:00

This incident is now resolved

Affected components

  • Applicant tracking

Monitoring | Apr 03, 2024 | 22:51 GMT-07:00

Emails are being delivered again. We appreciate your patience while we worked to restore the services.

Resolution in progress | Apr 03, 2024 | 07:41 GMT-07:00

JobScore is facing issues with delivering emails. The resolution is already in progress.

Accounts with the email sync feature enabled are not affected when exchanging emails with candidates. Only the platform notifications are affected.

Status Page powered by Admin Labs