Incident

JobScore went down

Closed | Oct 01, 2025 | 11:34 GMT-07:00

Incident closed

Affected components

  • Applicant tracking
  • Careers pages
  • Customer API

Resolved | Oct 01, 2025 | 10:10 GMT-07:00

The systems are back to normal. We are analyzing the logs to prevent that from happening in the future.

Investigating | Oct 01, 2025 | 09:52 GMT-07:00

We are investigating the root cause of the outage. Services are being restored.

Open | Oct 01, 2025 | 09:46 GMT-07:00

JobScore went down. We are working to restore the services.

Status Page powered by Admin Labs