Incident

System slowness

Closed | Oct 05, 2021 | 06:22 GMT-07:00

Closed

Affected components

  • Applicant tracking
  • Careers pages

Resolved | Jul 30, 2021 | 12:00 GMT-07:00

Two issues were identified:
Memory bloat caused by some heavy requests;
Sudden increase of connections to the website;

The service was restored and we will keep one eye on it.

Investigating | Jul 30, 2021 | 09:26 GMT-07:00

We are aware of the system slowness and we are investigating to mitigate the issue.

Status Page powered by Admin Labs