Closed | Feb 17, 2026 | 00:00 GMT-08:00
Closed
Monitoring | Feb 13, 2026 | 03:07 GMT-08:00
A few messages are still deferred, but will be delivered soon.
Resolution in progress | Feb 12, 2026 | 19:05 GMT-08:00
Microsoft has adjusted the reputation of our sending IP address to the correct level. Messages are being delivered again. It will take some time until all the messages are delivered by SendGrid
Investigating | Feb 12, 2026 | 08:30 GMT-08:00
We noticed a high volume of emails deferred to Microsoft mailboxes in SendGrid. We reached out to Microsoft and SendGrid to solve this issue.