Incident

Incident on Mar 11th, 2020

Resolved | Mar 11, 2020 | 12:30 GMT-07:00

This issue affecting the site performance was resolved. If you're still experiencing issues, please reach out to our support team for further assistance.

Affected components

  • Applicant tracking
  • Career pages

Monitoring | Mar 11, 2020 | 11:43 GMT-07:00

A fix has been deployed and we are monitoring the results.

Identified | Mar 11, 2020 | 11:40 GMT-07:00

The issue has been identified. More updates will be provided as they become available.

Investigating | Mar 11, 2020 | 11:08 GMT-07:00

We are currently experiencing performance issues. We are investigating the issue and will provide updates as they are available.

Status Page powered by Admin Labs