Incident

System Slowness

Closed | Jan 23, 2023 | 03:14 GMT-08:00

Incident Closed

Affected components

  • Applicant tracking
  • Careers pages

Resolved | Jan 20, 2023 | 12:51 GMT-08:00

Issue resolved. Systems are working again.

Monitoring | Jan 20, 2023 | 12:42 GMT-08:00

A fix was deployed. We are monitoring it

Resolution in progress | Jan 20, 2023 | 12:11 GMT-08:00

A slowness was identified in JobScore and the fix is underway.

Status Page powered by Admin Labs