Incident

Cloudflare Outage

Closed | Jul 20, 2020 | 11:55 GMT-07:00

Resolved

Affected components

  • Applicant tracking
  • Careers pages
  • Customer API

Resolved | Jul 17, 2020 | 15:59 GMT-07:00

The incident was resolved

Monitoring | Jul 17, 2020 | 15:12 GMT-07:00

Cloudflare identified the issue and implemented a fix. We are monitoring systems until they are stable again.

Monitoring | Jul 17, 2020 | 14:41 GMT-07:00

Systems are still unstable but some users are being able to connect.

Open | Jul 17, 2020 | 14:32 GMT-07:00

Users are currently having trouble connecting to our apps due to an upstream internet issue.

Status Page powered by Admin Labs